Responsive WordPress Theme – Caliber

A theme with simple controls and limitless potential. Work fast and build an amazing website!   Find out more »

UpThemes – Beautiful WordPress Themes

Create a site your church, gallery, newspaper, blog, recipes, band and more!   See the themes »

Need a little help?  Find answers quickly by searching the forum.
Group Admins
  • jeffw
  • andy

Support for: Mingle – Multi-purpose WordPress Theme

Mingle (WordPress)

Public Group  |  active 6 months, 1 week ago ago
Viewing post 1 to 13 (13 total posts)

Call to undefined function make_theme_blog_page()

  • lubiland

    said

    Hi guys,

    I have recently updated the theme and something happened. Cannot seem to update pages now, getting this error:

    I am able to say update sliders in design settings, so only getting this error when trying to update Page so far.

    Fatal error: Call to undefined function make_theme_blog_page() in /home/hea1th49/public_html/wp-content/themes/parallelus-mingle/framework/theme-functions/shortcodes.php on line 832

    The file looks like this:


    #-----------------------------------------------------------------
    # Blog output
    #-----------------------------------------------------------------
     
    // Blog output
    //...............................................
    function theme_blog( $atts, $content = null ) {
     
      return make_theme_blog_page($atts); //$return_content;
      
    }
    add_shortcode('blog', 'theme_blog');
     

    Any help you can provide what to do?

    I am running Version: 1.8.4.3.

    Thank you!

  • lubiland

    said

    Further investigation :)
    It seems only pages that contain shortcodes that are pulling posts are affected:


    [blog category="15" author_link="false" show_date="false" paging="false" post_content="excerpt" image_width="80" image_height="80"]
    [/one_half]
    [one_half_last]
    <h3>Osteopath</h3>
    [blog category="17" author_link="false" show_date="false" paging="false" post_content="excerpt" image_width="80" image_height="80"]
    <h3>Physiotherapist</h3>
    [blog category="18" author_link="false" show_date="false" paging="false" post_content="excerpt" image_width="80" image_height="80"]
    <h3>Nurses</h3>
    [blog category="16" author_link="false" show_date="false" paging="false" post_content="excerpt" image_width="80" image_height="80"]
    [/one_half_last]

    Page example here:

    https://www.healthcare.gg/cobo-surgery/

    Maybe this is something that got improved and I need to update these shortcodes?

    Other pages without this [blog] shortcodes are working fine.

    Thank you for any guidance you may provide.

  • jeffw

    said

    The error message you are getting – “Call to undefined function make_theme_blog_page()” – suggests that the theme is not installed properly. The reason I say this is because the make_theme_blog_page() function is a theme function, so an “‘undefined function” error most likely means that a core theme file is missing or corrupted.

    So let’s try reinstalling the theme. This is the exact procedure to follow…

         - Download the latest version of the Mingle theme from ThemeForest (the “Installable WordPress file only” option).
         - Unzip the file you downloaded from ThemeForest to create a ‘parallelus-mingle’ folder on your computer.
         - Use FTP to delete the ‘parallelus-mingle’ theme folder on your server.
         - Use FTP to upload the new ‘parallelus-mingle’ theme folder from your computer to your server.

    Please don’t reinstall the theme any other way, please follow the instructions above exactly. If you do not follow these instructions exactly then you may lose your theme settings, i.e. they could all revert to the default settings.

    It is important that you download the theme again from ThemeForest because it has been known for zip files to become corrupted in transmission.

    It is also important that you first delete the existing ‘parallelus-mingle’ theme folder on your server before you upload the new one. If you don’t do this you could end up with a theme folder with missing files and a mixture of templates from older and newer versions of the theme, and that can cause problems.

    So it is very important that you first delete the existing ‘parallelus-mingle’ theme folder on your server before you upload the new one.

    Do not have multiple Vellum theme folders in ‘wp-content/themes’, that alone can cause unpredictable problems. If you feel the need to store old versions of the theme, either download them to your computer and store them there, or move them to another location on your server. When I need to do this I create a ‘backups’ folder in ‘wp-content’.

    After reinstalling, remember to refresh your browser’s caches so that it’s not using cached versions of the theme’s CSS and JavaScript files…
         → http://www.refreshyourcache.com/en/cache/

    Please give that a try and if you still have this issue afterwards let us know and we will work from there.

  • lubiland

    said

    Hi Jeff
    Thanks very much for the info. I have just done that, i.e. deleted theme folder via FTP, added the fresh copy from themeforest.

    I am still getting this error though when I try and save a page with [blog] shortcodes. Additionally, this method has reverted the site to a default skin, so I I have closed it down with a maintenance screen – and need to restore my custom skin please.

    I have a folder on my machine from when I did it last time “skin-8″
    Are you able to tell me where to put it? Cant seems to find the new location on server now…
    Anything esle I need to do liek update css files or just in settings select skin 8 once its on server somewhere?

    Thank you, please reply asap as site is down while I am doing this…. If you cannot help then please advice asap also as I can restore to a backup from this morning and start again with our earlier problem.

    Thank you!

  • lubiland

    said

    I have added style-skin-8.css file to server already

  • lubiland

    said

    I have added my folder to /assest/images/skins

    but the site still looks wrong….

  • lubiland

    said

    Jeff
    I had to restore to backup from yesterday
    cannot keep the site down this long
    will start again with the problem later

  • jeffw

    said

    I’m sorry, all those posts have confused the hell out of me.

    Have you reinstalled the theme like I asked you to? Exactly as I asked you to?

    You see, the thing is, if you are getting an “undefined function” error message that most likely means a core theme file is missing or corrupted. I don’t know how you can get an “undefined function” error message for any other reason.

    We are not experiencing any problems with the Mingle theme, and no other customer has reported this problem, so that pretty much tells us that the problem is unique to your set up.

    Once you have reinstalled the theme, exactly as I described in my previous post, if you still have this issue afterwards let us know and we will work from there. But we cannot progress to further troubleshooting steps until we know that the theme is installed properly.

    If you are having trouble adding your custom skin to the reinstalled theme, this tutorial should help you. → http://para.llel.us/support/tutorials/making-a-custom-stylesheet-skin-with-mingle/

  • lubiland

    said

    To start again:

    updating the theme with your instructions did not solve the problem [blog} shortcodes issue
    but created a new one (skin) issue

    SO, I am now restored back to last nights backup and live again, but still unable to save pages with blog shortcodes

    Actually, the pages are being saved, but the error message loads each time. I can then click on “back” in the browser and see the page live on site.

    Seems like admin screens issue to me…

    I can provide you with logins if you would be willing to have a look?

    Thanks
    Lauren

  • jeffw

    said

    I have just searched this forum for “Call to undefined function make_theme_blog_page()” and got some hits, all from more than 5 years ago…

         → http://para.llel.us/support/groups/mingle-wordpress/forum/topic/fatal-error-call-to-undefined-function-make_theme_blog_page-mingle/
         → http://para.llel.us/support/groups/mingle-wordpress/forum/topic/blog-post-creation-and-update-error/
         → http://para.llel.us/support/groups/mingle-wordpress/forum/topic/short-codes-inside-short-codes/

    These customers got the same error message as the one you are seeing, and it was caused by a plugin conflict. The plugins that caused the problem were Search Unleashed and WiziApp.

    So there’s a good chance that you are also seeing that error message because of a plugin conflict.

    To check for a plugin conflict, deactivate all plugins, all at the same time. If the problem goes away, reactivate your additional plugins one at a time (individually, not incrementally) until you find the one responsible.

  • lubiland

    said

    Thanks Jeff, I will have a look at this. Sorry for confusing you with the messages, was in a bit of a panic, really sorry.
    Thanks again, will let you know if I can fix the issue.

  • lubiland

    said

    Hi Jeff

    Thank you for the info, I only have 5 plug-ins so this was easy to find. It seems the Yoast SEO is the plug-in responsible.

    What now?

  • jeffw

    said

    Alas, if Mingle is now incompatible with Yoast SEO there isn’t anything we will be able to do about it.

    It’s possible that the problem is being caused by just one function of the plugin, one that can be enabled/disabled. Check the plugin options to see if it has a setting that lets you disable indexing of shortcodes, and if so disable that feature. (But this is only a guess.)

    You could try asking the plugin author about it?

    Or can you find another SEO plugin that is compatible? I have used SEO Ultimate in the past with Mingle, don’t recall having any problems with it.

Viewing post 1 to 13 (13 total posts)